Backup problems

Home Forums Topics by OpenProducts Announcements Backup problems

Tagged: ,

This topic contains 4 replies, has 3 voices, and was last updated by pa pa 3 years, 2 months ago.

  • Author
    Posts
  • #485
    Tor Krill
    Tor Krill
    Keymaster

    Dear all,

    Tl;dr if you are affected by the remote backup problem. This issue should be resolved but you have to contact support to get a fix server side as well.

    The slightly longer version:

    As some of you have noticed we have had some initial problems affecting some users when enabling backup. I.e. the red LED where flashing and the admin UI indicated a backup error.

    Hopefully this is resolved now and we have released an update on the OPI-side for this. Unfortunately users affected by this also need to have their backup accounts reset on the server side by us. Please contact support

    /Tor

    EDIT:
    Note that the fix for this is currently not included in the SW shipped in OPI, it comes as an upgrade which is done every night. So if the backup is enabled directly when first starting the unit, this problem will still occur.

    • This topic was modified 3 years, 2 months ago by pa pa.
  • #522

    marcelhuber
    Participant

    Hi Tor

    I assume the backup problem is not solved yet:

    /etc/cron.daily/logrotate:
    initctl: invalid command: reopen-logs
    Try 

    initctl –help’ for more information.
    invoke-rc.d: initscript php5-fpm, action “reopen-logs” failed.
    error: error running non-shared postrotate script for /var/log/php5-fpm.log of ‘/var/log/php5-fpm.log ‘
    run-parts: /etc/cron.daily/logrotate exited with return code 1
    /etc/cron.daily/opi_backup:
    Backup failed (Possibly more informaton in log file: /var/log/opi-backup/backup.log)
    run-parts: /etc/cron.daily/opi_backup exited with return code 1
    `

    At least with regard to php.

    Thank you for your support.

  • #524
    pa
    pa
    Keymaster

    Hi Marcel,

    The backup is solved, but it requires that your account on our side is reset, so please come back to us with your unit_id (activation code) so that we can reset the account. Please send this in an email to our support mail, support@openproducts.com.

    Regarding the log rotate problem, this is an upstream bug that we have become aware of. We need to take a decision if we shall wait for an upstream fix or try to do a “opi-only” fix.

    /PA

    • #525

      marcelhuber
      Participant

      Hi Pa

      I was just curious as I activated and installed the device and enabled the backup yesterday ( sept. 27th ). So I thought my ‘account’ in this sense was activated yesterday and it must be a different problem.
      Probably you should more clearly state that it affects any new user registered at opi on or before…

      Thanks Pa, I will then hand in the numbers.

  • #526
    pa
    pa
    Keymaster

    Hi Marcel,

    Most likely as you write that you activated the unit and also directly enabled backup is what caused the problem. The fix is in the repositories, but the unit needs to update first which it does nightly (UTC time)

    But as you say, we should add this to the documentation, thank you.

    /PA

You must be logged in to reply to this topic.

Posted in