Security Questions: ShellShock Bash and Heartbleed

Home Forums User Contributions Uncategorized Security Questions: ShellShock Bash and Heartbleed

Tagged: 

This topic contains 2 replies, has 2 voices, and was last updated by Tor Krill Tor Krill 3 years, 2 months ago.

  • Author
    Posts
  • #504

    Andrew
    Participant

    Does OPI contain either the ShellShock Bash vulnerability (see: http://securitywatch.pcmag.com/internet/327769-serious-bash-flaw-lets-attackers-hijack-linux-and-mac-computers) or the Heartbleed bug (see: http://heartbleed.com/)?

    Thanks,
    Andrew

    P.S. I am eagerly looking forward to receiving my OPI soon!

  • #510
    Tor Krill
    Tor Krill
    Keymaster

    Hi Andrew,

    OPI does unfortunately indeed currently have a Bash version that is vulnerable for ShellShock.

    The upgrade is in the pipeline and will be distributed shortly. I will update this topic when we have released the bash upgrade.

    Regarding Heartbleed, this should be no issue since this is patched on Ubuntu since quite some time.

    /Tor

    • This reply was modified 3 years, 2 months ago by Tor Krill Tor Krill. Reason: Added Heartbleed comment
  • #528
    Tor Krill
    Tor Krill
    Keymaster

    Just a follow up here.

    We just pulled the Ubuntu updates on bash into our stable repositories. This means that all OPIs that have updates enabled should get this update shortly (~24h)

    /Tor

You must be logged in to reply to this topic.

Posted in